What to do when Plasma cant load providors.xml

As a Unity refugee I have tried ricing several DE’s to get my desktop environment where I want. I currently am using Plasma 5.13 as the new blur effects and globalmenu improvements won me over.

Customizing Plasma 5.x

Plasma 5 is interesting. Instead of relying on extensions, they plug directly into KDE-Look.org via store.kde.com. This works great as collection of themes and icons are integrated into the desktop environment. Howevever, it references an old URL and if you clear out your dotfiles or install KDE from source you may not have this correction.

Fixing the issue.

Thankfully, this bug has been worked around here in which you basically load the providers.xml from kde.org manually.

Begin by opening autoconfig.kde.org/ocs/providers.xml in your browser. Copy the entire contents of the .xml file and open your terminal.

cd to /etc/xdg and touch a new file by running sudo touch ./providers.xml.

Open the file as root using your favorite text editor and paste in the resulting .xml.

At the time of this writing this is the correct xml:

<providers>
 <provider>
   <id>api.kde-look.org</id>
     <location>https://api.kde-look.org/ocs/v1/</location>
     <name>api.kde-look.org</name>
     <termsofuse>https://api.kde-look.org/content/terms</termsofuse>
     <register>https://api.kde-look.org/register</register>
     <services>
       <person ocsversion="1.6"/>
       <content ocsversion="1.6"/>
     </services>
 </provider>
</providers>

I hope this helps you on your quest for *nix eyecandy!

Next
Previous
comments powered by Disqus